Blog

first ride

By 6 Mar ’05 No Comments

I had my first ride of the year today. Damn it’s been too long! The first thing were my tyres – Both of them almost flat then I found that the rear brake was pulling all the way to the bar delivering no power what so ever. Maybe cause the bike has been sat up on its rear wheel the brake fluid drained out somewhere but there were no leaks or spots of fluid anywhere.

The ride itself was pretty non eventful. I had to drop my keys off to my Boss in “Da Bush” So I just rode there and back with a slight detour through Gunnersbury Park on the way back. It was too damn cold and my a**e was getting sore. I am a riding wuss. Really need to sort my s**t out and ride more regularly! Roll on summertime and better weather days…..

Of course I didn’t use my new camera for these pics – I never charged it fully and I left the charger in work!!!

On Friday Eve I did the epic task of getting my TV back to my place. My back and shoulders are in PAIN! We got into town and the only place to park outside the office was a double yellow which meant I had to drag the TV up the stairs myself……. Behemoth TV V’s Mark = Very bloody difficult task. I got about 2/3rds of the way up and it got difficult – it was a major battle to stop it from sliding down to the bottom again.

Once I had it up the top I got it out onto the street in a relatively more easy fashion and we went to put it in the back of the car. I asked this bloke who was having a smoke to help out and YEA the box wouldn’t fit! DOH!!!!! We took it out of the box and got it in. – Dunno what I would have done had it not been for that kind Japanese bloke.

Final stage was on Sat afternoon – I went in search of a table to sit it on. £20 bought me a wicked lil table from a 2nd hand TV store.

I also got my replacement watch. – Anyway gonna stoop now and go to bed.

Mark

Author Mark

More posts by Mark

Leave a Reply